Add a doc target and use the defined source feeds to make symlinks
authorFlorian Fainelli <florian@openwrt.org>
Fri, 5 Jan 2007 15:34:14 +0000 (15:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 5 Jan 2007 15:34:14 +0000 (15:34 +0000)
SVN-Revision: 5993

Makefile

index daadbeacf65a7bb4ecd22f745ef4a3d828dfcbaf..a3d5720db3b2b0eb7df3e8658c4c77e801da6d70 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -181,8 +181,14 @@ distclean: dirclean config-clean
 help:
        cat README
 
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 symlinks:
-       scripts/feeds.sh https://svn.openwrt.org/openwrt/packages
+       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;