build: remove SDK special case for kernel module packages
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 Jan 2016 23:11:13 +0000 (23:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 Jan 2016 23:11:13 +0000 (23:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48207

include/kernel.mk

index 878a366fc4dc9ef2199c66a1c048258e28469659..57185c5fd3938ad9ac257d4580ab5c979e46760e 100644 (file)
@@ -180,7 +180,7 @@ $(call KernelPackage/$(1)/config)
   $(call KernelPackage/depends)
 
   ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m y,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
-    ifneq ($(if $(SDK),$(filter-out $(LINUX_DIR)/%.ko,$(FILES)),$(strip $(FILES))),)
+    ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  @for mod in $$(call version_filter,$$(FILES)); do \
                        if grep -q "$$$$$$$${mod##$(LINUX_DIR)/}" "$(LINUX_DIR)/modules.builtin"; then \