mac80211: rt2x00: no longer use TXOP_BACKOFF for probe frames
authorDaniel Golle <daniel@makrotopia.org>
Mon, 28 May 2018 13:45:43 +0000 (15:45 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 28 May 2018 13:49:41 +0000 (15:49 +0200)
Import a revert-commit from Stanislaw Gruszka which significantly
improves WiFi performance on rt2x00 based hardware.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/mac80211/Makefile
package/kernel/mac80211/patches/090-Revert-rt2800-use-TXOP_BACKOFF-for-probe-frames.patch [new file with mode: 0644]

index 77a3e68f5ccc46bc8de3b95d7d62fb0913eaf1a5..5666850eea9cd0bc5d1f59f97038e88e39515401 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 PKG_NAME:=mac80211
 
 PKG_VERSION:=2017-11-01
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
 PKG_HASH:=8437ab7886b988c8152e7a4db30b7f41009e49a3b2cb863edd05da1ecd7eb05a
 
diff --git a/package/kernel/mac80211/patches/090-Revert-rt2800-use-TXOP_BACKOFF-for-probe-frames.patch b/package/kernel/mac80211/patches/090-Revert-rt2800-use-TXOP_BACKOFF-for-probe-frames.patch
new file mode 100644 (file)
index 0000000..53d1c8a
--- /dev/null
@@ -0,0 +1,47 @@
+From patchwork Mon May 28 11:25:06 2018
+Content-Type: text/plain; charset="utf-8"
+MIME-Version: 1.0
+Content-Transfer-Encoding: 7bit
+Subject: Revert "rt2800: use TXOP_BACKOFF for probe frames"
+From: Stanislaw Gruszka <sgruszka@redhat.com>
+X-Patchwork-Id: 10431861
+Message-Id: <1527506706-6488-1-git-send-email-sgruszka@redhat.com>
+To: linux-wireless@vger.kernel.org
+Date: Mon, 28 May 2018 13:25:06 +0200
+
+This reverts commit fb47ada8dc3c30c8e7b415da155742b49536c61e.
+
+In some situations when we set TXOP_BACKOFF, the probe frame is
+not sent at all. What it worse then sending probe frame as part
+of AMPDU and can degrade 11n performance to 11g rates.
+
+Cc: stable@vger.kernel.org
+Signed-off-by: Stanislaw Gruszka <sgruszka@redhat.com>
+---
+ drivers/net/wireless/ralink/rt2x00/rt2x00queue.c | 7 +++----
+ 1 file changed, 3 insertions(+), 4 deletions(-)
+
+diff --git a/drivers/net/wireless/ralink/rt2x00/rt2x00queue.c b/drivers/net/wireless/ralink/rt2x00/rt2x00queue.c
+index a6884e73d2ab..7ddee980048b 100644
+--- a/drivers/net/wireless/ralink/rt2x00/rt2x00queue.c
++++ b/drivers/net/wireless/ralink/rt2x00/rt2x00queue.c
+@@ -372,16 +372,15 @@ static void rt2x00queue_create_tx_descriptor_ht(struct rt2x00_dev *rt2x00dev,
+       /*
+        * Determine IFS values
+-       * - Use TXOP_BACKOFF for probe and management frames except beacons
++       * - Use TXOP_BACKOFF for management frames except beacons
+        * - Use TXOP_SIFS for fragment bursts
+        * - Use TXOP_HTTXOP for everything else
+        *
+        * Note: rt2800 devices won't use CTS protection (if used)
+        * for frames not transmitted with TXOP_HTTXOP
+        */
+-      if ((ieee80211_is_mgmt(hdr->frame_control) &&
+-           !ieee80211_is_beacon(hdr->frame_control)) ||
+-          (tx_info->flags & IEEE80211_TX_CTL_RATE_CTRL_PROBE))
++      if (ieee80211_is_mgmt(hdr->frame_control) &&
++          !ieee80211_is_beacon(hdr->frame_control))
+               txdesc->u.ht.txop = TXOP_BACKOFF;
+       else if (!(tx_info->flags & IEEE80211_TX_CTL_FIRST_FRAGMENT))
+               txdesc->u.ht.txop = TXOP_SIFS;