modules: fixes ko files that were renamed in 3.1
authorJohn Crispin <john@openwrt.org>
Thu, 3 Nov 2011 15:16:50 +0000 (15:16 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 3 Nov 2011 15:16:50 +0000 (15:16 +0000)
SVN-Revision: 28724

package/kernel/modules/i2c.mk
package/kernel/modules/spi.mk

index eb3ac83576f0885812751c46f16f1263fe6cd4ee..0d525cc6d34a18bf0f106056acf0afa04763630e 100644 (file)
@@ -293,8 +293,13 @@ endef
 
 $(eval $(call KernelPackage,i2c-mux-pca9541))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCA953X_MODULES:= \
+  CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
+else
 GPIO_PCA953X_MODULES:= \
   CONFIG_GPIO_PCA953X:drivers/gpio/pca953x
+endif
 
 define KernelPackage/pca953x
   $(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
@@ -308,8 +313,13 @@ endef
 
 $(eval $(call KernelPackage,pca953x))
 
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+GPIO_PCF857X_MODULES:= \
+  CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
+else
 GPIO_PCF857X_MODULES:= \
   CONFIG_GPIO_PCF857X:drivers/gpio/pcf857x
+endif
 
 define KernelPackage/pcf857x
   $(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
index 7cb2a354dc2792d1d58ce2a1a88cfbc6c4db1b02..0c187b3a2fbf0918230f8f3811e526c6a6e3da8b 100644 (file)
@@ -62,8 +62,13 @@ define KernelPackage/spi-gpio
   TITLE:=GPIO-based bitbanging SPI Master
   DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_GPIO
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
+  AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+else
   FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio.ko
   AUTOLOAD:=$(call AutoLoad,92,spi_gpio)
+endif
 endef
 
 define KernelPackage/spi-gpio/description