kernel: This adds support for Marvell S-ATA.
authorJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 12:45:50 +0000 (12:45 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 30 Nov 2011 12:45:50 +0000 (12:45 +0000)
Useful for kirkwood and probably other Marvell SoCs.

Signed-off-by: Daniel Golle <dgolle@allnet.de>
SVN-Revision: 29364

package/kernel/modules/block.mk

index 6d67e72f72febae61e29999db6e46894afd9c4fb..ae05701b87883479923b944d8ccc0ff323821c72 100644 (file)
@@ -75,6 +75,21 @@ endef
 $(eval $(call KernelPackage,ata-artop))
 
 
+define KernelPackage/ata-marvell-sata
+  TITLE:=Marvell Serial ATA support
+  KCONFIG:=CONFIG_SATA_MV
+  FILES:=$(LINUX_DIR)/drivers/ata/sata_mv.ko
+  AUTOLOAD:=$(call AutoLoad,41,sata_mv,1)
+  $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-marvell-sata/description
+ SATA support for marvell chipsets
+endef
+
+$(eval $(call KernelPackage,ata-marvell-sata))
+
+
 define KernelPackage/ata-nvidia-sata
   TITLE:=Nvidia Serial ATA support
   KCONFIG:=CONFIG_SATA_NV