build: move append-string to image-commands.mk
authorMathias Kresin <dev@kresin.me>
Mon, 17 Dec 2018 20:47:16 +0000 (21:47 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 17 Dec 2018 22:21:26 +0000 (23:21 +0100)
Move it to image-commands.mk so that it can used by other targets.

Signed-off-by: Mathias Kresin <dev@kresin.me>
include/image-commands.mk
target/linux/ar71xx/image/generic.mk

index 63539bad0808c01fed3811f70b3857a33385c346..49138a216d5242710f0fe22af91c08cc1ff37142 100644 (file)
@@ -102,6 +102,10 @@ define Build/append-squashfs-fakeroot-be
        cat $@.fakesquashfs >> $@
 endef
 
+define Build/append-string
+       echo -n $(1) >> $@
+endef
+
 # append a fake/empty uImage header, to fool bootloaders rootfs integrity check
 # for example
 define Build/append-uImage-fakehdr
index 05428039d37bd40c8c16d6c58959d727b7067cf7..45c6d753993b085b1583153440e051a1a94722b8 100644 (file)
@@ -12,10 +12,6 @@ define Build/append-md5sum-bin
                xargs echo -ne >> $@
 endef
 
-define Build/append-string
-       echo -n $(1) >> $@
-endef
-
 define Build/mkwrggimg
        $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
                -i $@ -o $@.imghdr -d /dev/mtdblock/1 \