Fix installation of hostap pci and plx driver This fixes an issue where installation...
[openwrt/staging/florian.git] / package / hostap-driver / Makefile
index 5be9f9eb59dda12cff2ce215472656c03a49a926..30b8ca05a639f400e17ef4d290cfd87354753c64 100644 (file)
@@ -4,7 +4,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -46,8 +45,9 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +wireless-tools
   KCONFIG:=CONFIG_HOSTAP
+  PROVIDES:=kmod-hostap
 endef
 
 define KernelPackage/hostap/2.4
@@ -174,6 +174,10 @@ else
   endef
 endif
 
+define KernelPackage/hostap/install
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/lib/wifi/hostap.sh $(1)/lib/wifi
+endef
 
 $(eval $(call KernelPackage,hostap))
 $(eval $(call KernelPackage,hostap-cs))