adapt profiles for subtarget changes
[openwrt/staging/florian.git] / target / linux / amcc / Makefile
index 4dd366caa9ac34685be7fd25397def5e4d1e48fe..d582d8191531f6b24d956e7eb1b49f4863558263 100644 (file)
@@ -13,13 +13,10 @@ FEATURES:=jffs2
 
 LINUX_VERSION:=2.6.21.5
 
+include $(INCLUDE_DIR)/target.mk
+
 define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))