adapt profiles for subtarget changes
[openwrt/staging/florian.git] / target / linux / at91 / Makefile
index f8ca6f6be37d05b6021a28b6050b6d4d4e6011cb..dfa3bfbb65417605c60e9ca3958c0ffe36493fe4 100644 (file)
@@ -14,14 +14,12 @@ FEATURES:=squashfs usb
 #LINUX_VERSION:=2.6.21.5
 LINUX_VERSION:=2.6.22.4
 
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:="uImage"
+
 define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-
-#include the profiles
--include profiles/*.mk
-
-KERNELNAME:="uImage"
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))