u-boot.mk: always link host libraries static
authorAndre Heider <a.heider@gmail.com>
Tue, 19 Oct 2021 09:08:46 +0000 (11:08 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 24 Oct 2021 16:00:49 +0000 (18:00 +0200)
Host libraries are only build static, so let's pass --static to
pkg-config globally and remove the then unnecessary patches doing
exactly that individually.

Signed-off-by: Andre Heider <a.heider@gmail.com>
include/u-boot.mk
package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch [deleted file]
package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch [deleted file]
package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch [deleted file]

index 8c6941b88ac5d99b4338405c7de50b83bdeec3e1..509b3d76dc54064965a15df5356a4fbbdb6d0d5e 100644 (file)
@@ -48,6 +48,7 @@ UBOOT_MAKE_FLAGS = \
        STAGING_PREFIX="$(STAGING_DIR_HOST)" \
        PKG_CONFIG_PATH="$(STAGING_DIR_HOST)/lib/pkgconfig" \
        PKG_CONFIG_LIBDIR="$(STAGING_DIR_HOST)/lib/pkgconfig" \
+       PKG_CONFIG_EXTRAARGS="--static" \
        $(if $(findstring c,$(OPENWRT_VERBOSE)),V=1,V='')
 
 define Build/U-Boot/Target
diff --git a/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch b/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
deleted file mode 100644 (file)
index 2e7cf66..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-OpenWrt links the libressl statically against mkimage, make sure all the 
-needed dependencies are added too.
-
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -168,7 +168,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
- HOSTCFLAGS_kwbimage.o += \
-       $(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
- HOSTLDLIBS_mkimage += \
--      $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-+      $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
- # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
- # warnings on those systems
diff --git a/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch b/package/boot/uboot-mxs/patches/210-link-libcrypto-static.patch
deleted file mode 100644 (file)
index 022e798..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-OpenWrt links the libressl statically against mkimage, make sure all the 
-needed dependencies are added too.
-
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -147,7 +147,7 @@ endif
- # MXSImage needs LibSSL
- ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
- HOSTLOADLIBES_mkimage += \
--      $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-+      $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
- # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
- # warnings on those systems
diff --git a/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch b/package/boot/uboot-zynq/patches/210-link-libcrypto-static.patch
deleted file mode 100644 (file)
index d2e7bf1..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-OpenWrt links the libressl statically against mkimage, make sure all the 
-needed dependencies are added too.
-
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -151,7 +151,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
- HOSTCFLAGS_kwbimage.o += \
-       $(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
- HOSTLOADLIBES_mkimage += \
--      $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-+      $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
- # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
- # warnings on those systems