arm-trusted-firmware-mvebu: remove unpacked sources upon clean
authorAndre Heider <a.heider@gmail.com>
Tue, 8 Jun 2021 02:19:16 +0000 (04:19 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Jul 2021 11:52:39 +0000 (13:52 +0200)
These are all unpacked in the Build/Prepare step, clean up accordingly.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile

index c4669edb52b2bac87de3d3ee76338db6c8efcadd..6fc5e44e1ca75db1794c6c2879f956ca7a1eebe4 100644 (file)
@@ -155,6 +155,13 @@ define Download/gcc-linaro
   HASH:=2d4a92d6c8b384ae404b2e02c1c412e3ec18f9b714135acf046b2b1b510e9ace
 endef
 
+define Build/Clean
+       rm -rf \
+               $(STAGING_DIR_IMAGE)/$(A3700_UTILS_NAME) \
+               $(STAGING_DIR_IMAGE)/$(MV_DDR_NAME) \
+               $(STAGING_DIR_IMAGE)/$(LINARO_NAME)-$(LINARO_RELEASE).$(LINARO_VERSION)
+endef
+
 define Build/Prepare
        # Download sources
        $(eval $(call Download,a3700-utils))