ath79: glinet_gl-ar750s: Add USB power & microSD
authorAlexander Wördekemper <alexwoerde@web.de>
Thu, 16 May 2019 14:24:43 +0000 (16:24 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 20 May 2019 19:25:00 +0000 (21:25 +0200)
The GL.iNet AR750S USB and microSD port is currently not working out of
the box.  GPIO 7 is used to control the power of the USB port. Add GPIO
7 as a fixed-regulator for the port.  Also add &usb1 to DTS to get the
microSD port to work.

Signed-off-by: Alexander Wördekemper <alexwoerde@web.de>
target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
target/linux/ath79/image/generic.mk

index 378de5de904468a10c47a7cc216cb67ecdd54bcf..0145a24fbae2cdbe6fb6445607795af6b792352d 100644 (file)
                        linux,default-trigger = "phy0tpt";
                };
        };
                        linux,default-trigger = "phy0tpt";
                };
        };
+
+       usb_vbus: regulator-usb-vbus {
+               compatible = "regulator-fixed";
+
+               regulator-name = "USB_VBUS";
+
+               regulator-min-microvolt = <5000000>;
+               regulator-max-microvolt = <5000000>;
+               regulator-always-on;
+
+               gpio = <&gpio 7 GPIO_ACTIVE_HIGH>;
+               enable-active-high;
+       };
 };
 
 &spi {
 };
 
 &spi {
 };
 
 &usb0 {
 };
 
 &usb0 {
-       #address-cells = <1>;
-       #size-cells = <0>;
        status = "okay";
        status = "okay";
-
-       hub_port: port@1 {
-               reg = <1>;
-               #trigger-source-cells = <0>;
-       };
+       vbus-supply = <&usb_vbus>;
 };
 
 &usb_phy0 {
        status = "okay";
 };
 
 };
 
 &usb_phy0 {
        status = "okay";
 };
 
+&usb1 {
+       status = "okay";
+};
+
+&usb_phy1 {
+       status = "okay";
+};
+
 &mdio0 {
        status = "okay";
        phy-mask = <0>;
 &mdio0 {
        status = "okay";
        phy-mask = <0>;
index dd5843d43695ab5bdcd72d1635b58490d4745deb..b8558a59f0cc6f737d3b8b7597e86992661bfb14 100644 (file)
@@ -383,7 +383,7 @@ TARGET_DEVICES += glinet_gl-ar300m-nor
 define Device/glinet_gl-ar750s
   ATH_SOC := qca9563
   DEVICE_TITLE := GL.iNet GL-AR750S
 define Device/glinet_gl-ar750s
   ATH_SOC := qca9563
   DEVICE_TITLE := GL.iNet GL-AR750S
-  DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct
+  DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct block-mount
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef
   IMAGE_SIZE := 16000k
   SUPPORTED_DEVICES += gl-ar750s
 endef