toolchain/binutils: get rid of ARC leftovers
authorAndre Heider <a.heider@gmail.com>
Wed, 8 Feb 2023 17:04:25 +0000 (18:04 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000 (19:44 +0100)
In [0] support for ARC specific binutils were added, which was later removed
again [Fixes:].

Upstream binutils never had an extlib.

[0] 8b5d644b "toolchain: add support of ARC architecture"

Fixes: 8568dcd9 "toolchain: Remove binutils 2.29 for ARC targets"
Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/binutils/Makefile

index af670f56467ebf6c648917615be78fd65887030d..0b7558e3584afb89b5b73e684910ab9a37a528e5 100644 (file)
@@ -102,12 +102,6 @@ define Host/Install
        $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
        $(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
        $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
-       # ARC gcc requires extlib.
-       # If extlib is not available in "initial" folder
-       # initial gcc will fail to build libc.
-       if [ -d $(TOOLCHAIN_DIR)/extlib ]; then \
-               $(CP) -r $(TOOLCHAIN_DIR)/extlib $(TOOLCHAIN_DIR)/initial/; \
-       fi
 endef
 
 define Host/Clean