include/package.mk: remove old configured stamps before attempting configuration
authorMatthias Schiffer <mschiffer@universe-factory.net>
Sun, 10 Dec 2017 14:30:30 +0000 (15:30 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Thu, 28 Dec 2017 11:24:25 +0000 (12:24 +0100)
Some packages, e.g. busybox, explicitly remove old .configured stamps
before attempting configuration, rather than after the actual configuration
step. This seems like a good idea, as there will be no stamp left if
configuration fails. Change generic rules to work like this, so package-
specific rules can be dropped.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
include/package.mk

index e804b02b049c3cb1d4bdce9acfb560ac7511ff9c..78ea5d0ef8b73e758466b48f4a9d652daae7d59c 100644 (file)
@@ -168,11 +168,11 @@ define Build/CoreTargets
 
   $(call Build/Exports,$(STAMP_CONFIGURED))
   $(STAMP_CONFIGURED): $(STAMP_PREPARED) $(STAMP_CONFIGURED_DEPENDS)
+       rm -f $(STAMP_CONFIGURED_WILDCARD)
        $(CleanStaging)
        $(foreach hook,$(Hooks/Configure/Pre),$(call $(hook))$(sep))
        $(Build/Configure)
        $(foreach hook,$(Hooks/Configure/Post),$(call $(hook))$(sep))
-       rm -f $(STAMP_CONFIGURED_WILDCARD)
        touch $$@
 
   $(call Build/Exports,$(STAMP_BUILT))