toolchain/gcc: use explicit configure args
authorAndre Heider <a.heider@gmail.com>
Tue, 31 Jan 2023 11:04:00 +0000 (12:04 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 9 Feb 2023 01:53:35 +0000 (02:53 +0100)
Spell out what we want to enable or disable. This prevents host libs to leak in,
so everyone get the same feature set.

Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/gcc/common.mk
toolchain/gcc/final/Makefile

index 7eae855eea42c7ba1d4a2166cf615b0ddcc0d8a1..5f314c7fc0bcccf8f75747eea2ad1fcbc1f2b857 100644 (file)
@@ -106,6 +106,8 @@ GCC_CONFIGURE:= \
                        --with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
                $(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
                $(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
+               --with-system-zlib=$(STAGING_DIR_HOST) \
+               --without-zstd \
                --with-gmp=$(STAGING_DIR_HOST) \
                --with-mpfr=$(STAGING_DIR_HOST) \
                --with-mpc=$(STAGING_DIR_HOST) \
index 049ddf61f03355281d8fb34087c48e3418d43cb1..78a5576bffb3b82659c8ad53584bdc69a76a8d53 100644 (file)
@@ -8,6 +8,7 @@ GCC_CONFIGURE += \
        --enable-shared \
        --enable-threads \
        --with-slibdir=$(TOOLCHAIN_DIR)/lib \
+       --enable-plugins \
        --enable-lto \
        --with-libelf=$(STAGING_DIR_HOST)