ltq-vdsl-app: use ubus to provide metrics
authorAndre Heider <a.heider@gmail.com>
Tue, 26 Jan 2021 08:00:50 +0000 (09:00 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 8 Feb 2021 20:43:00 +0000 (21:43 +0100)
luci now uses ubus directly, so remove 'lucistat'.
For manual usage just print the ubus output, use luci for a pretty
version.

Signed-off-by: Andre Heider <a.heider@gmail.com>
Tested-by: Martin Schiller <ms@dev.tdt.de>
package/network/config/ltq-vdsl-app/Makefile
package/network/config/ltq-vdsl-app/files/dsl_control

index 2e6faac42d816c61ae7cdfb90e1810df8ce57b1b..0968811984dace124730c0a9eef3091f00dabcaa 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-app
 PKG_VERSION:=4.17.18.6
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@OPENWRT
index 5089d7ac31a1fc8a033b82b14685f83b182d3fa3..54b739e2cd9d00eae0c6ba4b04ab362e47f36782 100644 (file)
@@ -4,10 +4,11 @@
 START=97
 USE_PROCD=1
 
-extra_command "dslstat" "Get DSL status information"
-extra_command "lucistat" "Get status information in lua friendly format"
+dslstat() {
+       ubus call dsl metrics
+}
 
-. /lib/functions/lantiq_dsl.sh
+extra_command "dslstat" "Get DSL status information"
 
 #
 # ITU-T G.997.1 (06/2012) - Section 7.3.1.1.1 (xTU transmission system enabling (XTSE))