arm-trusted-firmware-mvebu: update a3700-tools to current master
authorAndre Heider <a.heider@gmail.com>
Tue, 8 Jun 2021 02:20:26 +0000 (04:20 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Jul 2021 11:52:39 +0000 (13:52 +0200)
2efdb10 wtmi: Fix calculation of UART divider
4247e39 fix: twin die ddr porting guide
8ad7992 sys_init: Add missing newlines in debug mode
4ddea19 avs: Validate VDD value from OTP
c444aeb avs: Fix description for avs value 0x2e
1915b78 tim: Optimize code generated by gettimver.sh and print newline
21f566d tim: Print mv_ddr version and configuration on UART
840b70b tim: Use variable $DDRFILE where possible
c10e6ae tim: Fix waiting for UART TX ready
7bf95cf wtmi: Wait 3ms for the TX on UART to be empty prior resetting TX FIFO
63e8433 wtmi: Add "dirty" suffix to git commit and rebuild sys_init.bin binary when VERSION changes
e949b58 wtmi: During setup clock phase print CPU and DDR speed
10376b5 wtmi: Flush output on UART after the '\n' character
509c647 Makefile: Check that specified DDR_TOPOLOGY option is valid

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile
package/boot/arm-trusted-firmware-mvebu/patches-a3700-utils/001-version.patch

index 7fefee38460c9f2bd21219f680ecb6393fd11512..bd03a6a32e254c70eb4d69d42d9d486d75e8997e 100644 (file)
@@ -122,15 +122,15 @@ TFA_MAKE_FLAGS += \
                mrvl_uart
 
 A3700_UTILS_NAME:=a3700-utils
-A3700_UTILS_RELEASE:=5598e150
+A3700_UTILS_RELEASE:=2efdb10f
 A3700_UTILS_SOURCE=$(A3700_UTILS_NAME)-$(A3700_UTILS_RELEASE).tar.bz2
 
 define Download/a3700-utils
   FILE:=$(A3700_UTILS_SOURCE)
   PROTO:=git
   URL:=https://github.com/MarvellEmbeddedProcessors/A3700-utils-marvell.git
-  VERSION:=5598e150fa3a1568256c30223fd2b214d729f26a
-  MIRROR_HASH:=4c3a3bed97833d08af4e42995c0c5af6c107f990fd492cd90aa3e79134d2751e
+  VERSION:=2efdb10f3524c534d276002adf81fec06e0f1cf2
+  MIRROR_HASH:=4476e1bacfa7abb4a1303c6cf3aa7d067038b24090dfd5da13ca2a72a0d5c7a4
   SUBDIR:=$(A3700_UTILS_NAME)
 endef
 
index 745e6150745ec77d0f3cf8a4eeefa2d8befcbc0d..0519598a281955cc4b65d357b9870efd69ffe63d 100644 (file)
@@ -1,13 +1,14 @@
 diff --git a/wtmi/sys_init/Makefile b/wtmi/sys_init/Makefile
 --- a/wtmi/sys_init/Makefile
 +++ b/wtmi/sys_init/Makefile
-@@ -51,7 +51,8 @@ ECHO     = @echo
+@@ -51,8 +51,8 @@ ECHO     = @echo
  SED      = @sed
  
  LOCAL_VERSION_STRING  ?= -armada
--BUILD_STRING          := $(shell git log -n 1 --pretty=format:"%h")
-+A3700_UTILS_COMMIT_ID ?= $(shell git log -n 1 --pretty=format:"%h")
-+BUILD_STRING          := $(A3700_UTILS_COMMIT_ID)
- VERSION_STRING                := $(LOCAL_VERSION_STRING)-$(BUILD_STRING)
+-BUILD_STRING          := $(shell git log -n 1 --pretty=format:"%h" && (git diff-index --quiet HEAD || echo -dirty))
+-VERSION_STRING                := $(LOCAL_VERSION_STRING)-$(BUILD_STRING)
++A3700_UTILS_COMMIT_ID ?= $(shell git log -n 1 --pretty=format:"%h" && (git diff-index --quiet HEAD || echo -dirty))
++VERSION_STRING                := $(LOCAL_VERSION_STRING)-$(A3700_UTILS_COMMIT_ID)
  
  CPUOPTS  = -mthumb -mcpu=cortex-m3 -mlittle-endian
+ BINPATH  = build