toolchain: remove installing twice in the "initial" subdir
authorAndre Heider <a.heider@gmail.com>
Tue, 7 Feb 2023 20:33:33 +0000 (21:33 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000 (19:44 +0100)
This was apparently introduced to recreate the toolchain (wipe
staging_dir/toolchain*, but keep build_dir/toolchain*, followed by a
`make toolchain/compile`).

But it leaves leftovers and causes re-links to happen at src_install phase,
because of the changed paths, possibly adding yet another source of issues.

With the prior commits removing various hacks related to the "initial"
folder we can remove installing it twice altogether.

The recreated toolchain is exactly the same as before.

Signed-off-by: Andre Heider <a.heider@gmail.com>
target/sdk/Makefile
toolchain/binutils/Makefile
toolchain/gcc/initial/Makefile

index 89cc898e9d0e1b7527efad96a9136c553492d12e..d9f67dae9ef03774212bda06002e763aa6857f5f 100644 (file)
@@ -29,7 +29,6 @@ EXCLUDE_DIRS:= \
        */man \
        */info \
        */root-* \
-       initial \
        *.install.clean \
        *.install.flags \
        *.install \
index 636b8c4b11576165de87327e36c5b48ade1ebff6..42778d8d6987e9cf09eb67473fa26c831c70d670 100644 (file)
@@ -91,14 +91,9 @@ define Host/Compile
 endef
 
 define Host/Install
-       mkdir -p $(TOOLCHAIN_DIR)/initial
        $(MAKE) -C $(HOST_BUILD_DIR) \
-               prefix=$(TOOLCHAIN_DIR)/initial \
                install
-       $(MAKE) -C $(HOST_BUILD_DIR) \
-               prefix=$(TOOLCHAIN_DIR) \
-               install
-       $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
+       $(call FixupLibdir,$(TOOLCHAIN_DIR))
        $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
 endef
 
index 102fc070ae0d78907e73c6e75e62fe27dbf939be..7cb4a73dbce0f7813ff956178e3b942ec738b1d4 100644 (file)
@@ -19,12 +19,10 @@ endef
 
 define Host/Install
        +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) \
-               prefix="$(TOOLCHAIN_DIR)/initial" \
                install-gcc \
                install-target-libgcc
 
-       $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
-       $$(call file_copy,$(TOOLCHAIN_DIR)/initial/.,$(TOOLCHAIN_DIR)/)
+       $(call FixupLibdir,$(TOOLCHAIN_DIR))
 endef
 
 $(eval $(call HostBuild))