wolfssl: remove --enable-sha512 configure switch
authorAndre Heider <a.heider@gmail.com>
Sat, 2 Oct 2021 08:40:00 +0000 (10:40 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sun, 17 Oct 2021 14:30:12 +0000 (16:30 +0200)
It's the default anyway and this just looks confusing, as if it wasn't.

Switch to AUTORELEASE while at it.

The binary size is unchanged.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/libs/wolfssl/Makefile

index edbe95b654d22bbd28f3d9707308c20c442d7773..93f2cc3ac3022fff26cb6637681eb346d861bd4e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wolfssl
 PKG_VERSION:=4.8.1-stable
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/wolfSSL/wolfssl/archive/v$(PKG_VERSION)
@@ -104,7 +104,7 @@ endif
 
 ifeq ($(CONFIG_WOLFSSL_HAS_WPAS),y)
 CONFIGURE_ARGS += \
-       --enable-wpas --enable-sha512 --enable-fortress --enable-fastmath
+       --enable-wpas --enable-fortress --enable-fastmath
 endif
 
 define Build/InstallDev