base-files: set FAILSAFE in /etc/profile when /tmp/.failsafe exists
authorMatthias Schiffer <mschiffer@universe-factory.net>
Fri, 29 Dec 2017 13:34:03 +0000 (14:34 +0100)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Fri, 29 Dec 2017 13:34:03 +0000 (14:34 +0100)
Since dropbear clears the environment, FAILSAFE was not set as intended in
failsafe mode. This also broke sysupgrade from failsafe mode over SSH.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
package/base-files/Makefile
package/base-files/files/etc/profile

index 728d787e092a814c97b36636c5153829a56f5062..d0c9d6bc290066a50880de8c8eaeae3a0ab0151a 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/version.mk
 include $(INCLUDE_DIR)/feeds.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=179
+PKG_RELEASE:=180
 PKG_FLAGS:=nonshared
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
index 3eda09b456ba262e9836f3e669c01766c1e65479..8ac9d6dbb5e0d92f040480d738771f50d586d470 100644 (file)
@@ -1,6 +1,9 @@
 #!/bin/sh
+[ -e /tmp/.failsafe ] && export FAILSAFE=1
+
 [ -f /etc/banner ] && cat /etc/banner
-[ -e /tmp/.failsafe ] && cat /etc/banner.failsafe
+[ -n "$FAILSAFE" ] || cat /etc/banner.failsafe
+
 fgrep -sq '/ overlay ro,' /proc/mounts && {
        echo 'Your JFFS2-partition seems full and overlayfs is mounted read-only.'
        echo 'Please try to remove files from /overlay/upper/... and reboot!'