uhttpd: clean up Makefile
authorAndre Heider <a.heider@gmail.com>
Mon, 28 Nov 2022 09:06:07 +0000 (10:06 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 28 Jan 2023 21:37:35 +0000 (22:37 +0100)
uhttpd's cmake options all default to ON. Either we set all of them or
none if the defaults need to be changed. Let's go with the latter.

Because support for all modules is always compiled in, remove two unused
and useless config toggles.

uhttpd detects and uses libcrypt itself, no need to add it here again.

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/network/services/uhttpd/Makefile

index 4090bf457984f688ecf67147db3fd32b8df24436..3923e55b072e16b3a485a634b209a3f735e17d04 100644 (file)
@@ -20,7 +20,6 @@ PKG_LICENSE:=ISC
 
 PKG_ASLR_PIE_REGULAR:=1
 PKG_BUILD_DEPENDS = ustream-ssl
-PKG_CONFIG_DEPENDS:= CONFIG_uhttpd_lua CONFIG_uhttpd_ucode
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -44,18 +43,6 @@ define Package/uhttpd/description
  HTTP daemon.
 endef
 
-define Package/uhttpd/config
-  config uhttpd_lua
-    depends on PACKAGE_uhttpd-mod-lua
-    bool "Enable Integrated Lua interpreter"
-       default y
-
-  config uhttpd_ucode
-    depends on PACKAGE_uhttpd-mod-ucode
-    bool "Enable Integrated ucode interpreter"
-       default y
-endef
-
 define Package/uhttpd/conffiles
 /etc/config/uhttpd
 /etc/uhttpd.crt
@@ -101,17 +88,11 @@ ifneq ($(CONFIG_USE_GLIBC),)
   TARGET_CFLAGS += -D_DEFAULT_SOURCE
 endif
 
-TARGET_LDFLAGS += -lcrypt
-
-CMAKE_OPTIONS += -DTLS_SUPPORT=on
-
 define Package/uhttpd/install
-       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/init.d $(1)/etc/config $(1)/usr/sbin
        $(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
-       $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
        $(VERSION_SED_SCRIPT) $(1)/etc/config/uhttpd
-       $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
 endef