arm-trusted-firmware-mvebu: bump a3700-utils to current version
authorAndre Heider <a.heider@gmail.com>
Tue, 21 Jun 2022 12:08:55 +0000 (14:08 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 31 Jul 2022 16:53:23 +0000 (18:53 +0200)
1d97715 wtmi: Discard ELF symbols from firmware binary
2d2a21c wtmi: Allow access to the 43th OTP row
e733e9f Fix boot from SATA build
4392eaf wtmi: Fix sending status code of cmd execution
14b3c61 Wtpdownloader: Remove out-of-dated x86-64 ELF binary WtpDownload_linux
e345b95 Wtpdownloader: Fix setting tty c_cflag options
0c502d5 Wtpdownloader: Call HandlePendingMessages() after Port->WtpCmd is freed
d91761a Wtpdownloader: Fix memory leaks
bc11d18 Wtpdownloader: Check for number of read bytes prior touching read buffer
58db335 Wtpdownloader: Add missing check in SendContinuousForceConsoleMode() if byte was really read
a4029c0 Wtpdownloader: Fix 32/64-bit host detection
3679034 Wtpdownloader: Print missing newline at the end of output

Signed-off-by: Andre Heider <a.heider@gmail.com>
package/boot/arm-trusted-firmware-mvebu/Makefile

index 18b663768f92d6535c30b6544974f4250e896672..67fd536edf3e25a11d50ffe787e9c91890058f54 100644 (file)
@@ -124,15 +124,15 @@ TFA_MAKE_FLAGS += \
                mrvl_uart
 
 A3700_UTILS_NAME:=a3700-utils
-A3700_UTILS_RELEASE:=97f01f5f
+A3700_UTILS_RELEASE:=1d977157
 A3700_UTILS_SOURCE=$(A3700_UTILS_NAME)-$(A3700_UTILS_RELEASE).tar.bz2
 
 define Download/a3700-utils
   FILE:=$(A3700_UTILS_SOURCE)
   PROTO:=git
   URL:=https://github.com/MarvellEmbeddedProcessors/A3700-utils-marvell.git
-  VERSION:=97f01f5feaf9ef6168e2a2096abaf56371939e58
-  MIRROR_HASH:=1e391c4dafb7b3363a17282e229d056a95575c0f4fb2f71e21db8044668aea78
+  VERSION:=1d977157e37151b272f88f2406a245c833fb2d8c
+  MIRROR_HASH:=322821ec8c04afea260254e927c59cd1ec0bd84e7ec6507cc1f155f18afb8eb9
   SUBDIR:=$(A3700_UTILS_NAME)
 endef