ipq40xx: add support for FRITZ!Box 7520
authorAndre Heider <a.heider@gmail.com>
Sun, 5 Dec 2021 11:14:45 +0000 (12:14 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 25 Mar 2022 17:14:13 +0000 (18:14 +0100)
This model, also know as "1&1 HomeServer", shares the same features as 7530.

The vendor firmware has artificial software limitations: only 2 of the 4
LAN-Ports are GBit, and the USB-Host is only v2.0.

With OpenWrt, USB is already working at v3.0.

Signed-off-by: Andre Heider <a.heider@gmail.com>
(updated commit message to reflect current state)
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ipq40xx/image/generic.mk

index 94b00f833a5c5c0dfc9f16353db0c5859def047e..3354084a70800f05fe037ddf64960ac6de9362fd 100644 (file)
@@ -269,6 +269,8 @@ define Device/avm_fritzbox-7530
        $(call Device/FitImageLzma)
        DEVICE_VENDOR := AVM
        DEVICE_MODEL := FRITZ!Box 7530
+       DEVICE_ALT0_VENDOR := AVM
+       DEVICE_ALT0_MODEL := FRITZ!Box 7520
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
 endef