tools/mkimage: pass --static via PKG_CONFIG_EXTRAARGS
authorAndre Heider <a.heider@gmail.com>
Mon, 1 Nov 2021 06:59:21 +0000 (07:59 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Nov 2021 13:22:26 +0000 (14:22 +0100)
Remove the then unnecessary patch doing exactly that individually.

See also 09465d80 "u-boot.mk: always link host libraries static".

Signed-off-by: Andre Heider <a.heider@gmail.com>
tools/mkimage/Makefile
tools/mkimage/patches/210-link-libcrypto-static.patch [deleted file]

index 6901d921cfc63286705b9b5006d1bc9537c64b75..1eb713a22ada764dc95dc357a9023bd936617d1b 100644 (file)
@@ -32,6 +32,7 @@ define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) \
                HOSTCFLAGS="$(HOST_CFLAGS)" \
                HOSTLDFLAGS="$(HOST_LDFLAGS)" \
+               PKG_CONFIG_EXTRAARGS="--static" \
                no-dot-config-targets=tools-only \
                CONFIG_MKIMAGE_DTC_PATH=dtc \
                CONFIG_FIT=y \
diff --git a/tools/mkimage/patches/210-link-libcrypto-static.patch b/tools/mkimage/patches/210-link-libcrypto-static.patch
deleted file mode 100644 (file)
index 87a425b..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-OpenWrt links the libressl statically against mkimage, make sure all the 
-needed dependencies are added too.
-
---- a/tools/Makefile
-+++ b/tools/Makefile
-@@ -158,7 +158,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
- HOSTCFLAGS_kwbimage.o += \
-       $(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
- HOSTLDLIBS_mkimage += \
--      $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
-+      $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
- # OS X deprecate openssl in favour of CommonCrypto, supress deprecation
- # warnings on those systems