ath79: add support for UniFi AC-Mesh Pro
authorChristoph Krapp <achterin@googlemail.com>
Mon, 2 Jul 2018 12:39:54 +0000 (14:39 +0200)
committerMathias Kresin <dev@kresin.me>
Sat, 7 Jul 2018 19:07:40 +0000 (21:07 +0200)
The Unifi AC-Mesh Pro has identical hardware to the Unifi AC-Pro except
USB support.
Furthermore for setting parameters like antenna gain it is helpful to
know the exact device variant.

Signed-off-by: Christoph Krapp <achterin@googlemail.com>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dts
target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-ubnt.mk

index 10a1bbd9ec3a28478aa3e969de3438d8d4a0d7cd..dd75a55b73053f085e4aaf288476a74bc63d766d 100755 (executable)
@@ -114,6 +114,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth0" "3:lan:1" "5:lan:2" "4:wan"
                ;;
+       "ubnt,unifiac-mesh-pro"|\
        "ubnt,unifiac-pro")
                ucidef_add_switch "switch0" \
                        "0@eth0" "2:lan" "3:wan"
index 28cfa25f4d197fc31cc9dfc715db3fda2eaaa92d..240a1bf1dda2840dca9bd768ac04cdcfe1abddac 100644 (file)
@@ -101,6 +101,7 @@ case "$FIRMWARE" in
                ;;
        "ubnt,unifiac-lite"|\
        "ubnt,unifiac-mesh"|\
+       "ubnt,unifiac-mesh-pro"|\
        "ubnt,unifiac-pro")
                ath10kcal_extract "EEPROM" 20480 2116
                ;;
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-mesh-pro.dts
new file mode 100644 (file)
index 0000000..9d80217
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9563_ubnt_unifiac-pro.dtsi"
+
+/ {
+       compatible = "ubnt,unifiac-mesh-pro", "qca,qca9563";
+       model = "Ubiquiti UniFi-AC-MESH PRO";
+};
index 31ca0ab965a8aae5e8d56e2af0da69327f5bd400..41449bbfc3694bce53983a781875c39011647965 100644 (file)
@@ -1,11 +1,11 @@
 // SPDX-License-Identifier: GPL-2.0-or-later OR MIT
 /dts-v1/;
 
-#include "qca9563_ubnt_unifiac.dtsi"
+#include "qca9563_ubnt_unifiac-pro.dtsi"
 
 / {
        compatible = "ubnt,unifiac-pro", "qca,qca9563";
-       model = "Ubiquiti UniFi-AC-PRO/MESH PRO";
+       model = "Ubiquiti UniFi-AC-PRO";
 };
 
 &usb_phy0 {
 &usb0 {
        status = "okay";
 };
-
-&mdio0 {
-       status = "okay";
-       phy-mask = <0>;
-
-       phy0: ethernet-phy@0 {
-               reg = <0>;
-               phy-mode = "sgmii";
-               qca,ar8327-initvals = <
-                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
-                       0x7c 0x0000007e /* PORT0_STATUS */
-               >;
-       };
-};
-
-&eth0 {
-       status = "okay";
-
-       mtd-mac-address = <&eeprom 0x0>;
-       phy-handle = <&phy0>;
-};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dtsi b/target/linux/ath79/dts/qca9563_ubnt_unifiac-pro.dtsi
new file mode 100644 (file)
index 0000000..f218143
--- /dev/null
@@ -0,0 +1,24 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_ubnt_unifiac.dtsi"
+
+&mdio0 {
+       status = "okay";
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+               >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&eeprom 0x0>;
+       phy-handle = <&phy0>;
+};
index 540277d41b88850ca91fdbefcc74e1433fb0dcc6..4681996a7b2a4220b0929b06c4d1859a9f64b671 100644 (file)
@@ -103,6 +103,13 @@ define Device/ubnt_unifiac-mesh
 endef
 TARGET_DEVICES += ubnt_unifiac-mesh
 
+define Device/ubnt_unifiac-mesh-pro
+  $(Device/ubnt_unifiac)
+  DEVICE_TITLE := Ubiquiti UniFi AC-Mesh Pro
+  SUPPORTED_DEVICES += ubnt-unifiac-mesh-pro
+endef
+TARGET_DEVICES += ubnt_unifiac-mesh-pro
+
 define Device/ubnt_unifiac-pro
   $(Device/ubnt_unifiac)
   DEVICE_TITLE := Ubiquiti UniFi AC-Pro