toolchain/gcc: remove glibc libgcc_eh hack
authorAndre Heider <a.heider@gmail.com>
Thu, 9 Feb 2023 09:09:08 +0000 (10:09 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 19 Feb 2023 18:44:39 +0000 (19:44 +0100)
A modern glibc only links against libgcc_eh for its tests or when building it
static, which doesn't happen here.

Reverts a hunk of: a3edea1b "add support for alternative C libraries..."

Signed-off-by: Andre Heider <a.heider@gmail.com>
toolchain/gcc/initial/Makefile

index c71b17dd87b105963987b25babbcbad539c6708f..68a7ccd3c759778f42d3f96c1209cb028326bb50 100644 (file)
@@ -23,9 +23,7 @@ define Host/Install
                install-gcc \
                install-target-libgcc
 
-       # XXX: glibc insists on linking against libgcc_eh
        ( cd $(TOOLCHAIN_DIR)/initial/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
-               [ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
                cp libgcc.a libgcc_initial.a; \
        )