package/: fix $(PROJECT_GIT) usage
[openwrt/staging/jogo.git] / package / system / fstools / Makefile
index 1cdf6cd15328e7d90ce59afb2307d4973177a15f..cc02033706bfa3c7addf6cefdd4494d3b6b7aa44 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(LEDE_GIT)/project/fstools.git
-PKG_SOURCE_DATE:=2017-05-09
-PKG_SOURCE_VERSION:=c43ae11e71abf607a1998800f8ced489ec5d1e88
-PKG_MIRROR_HASH:=f305bfc6f2aed6f13e59581969d9da7cdf76a823f7e1fe3f1dfdc221788374dd
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
+PKG_SOURCE_DATE:=2018-05-23
+PKG_SOURCE_VERSION:=dd02dad332958575cc52e60c78ef10ef2b5aaced
+PKG_MIRROR_HASH:=31051da29a0fff0b60ab3fc7fe27be281ed298346ff0ac65e3a2976671d2deed
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
@@ -33,6 +33,8 @@ include $(INCLUDE_DIR)/cmake.mk
 
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
 
 define Package/fstools
   SECTION:=base
@@ -50,6 +52,20 @@ define Package/fstools/config
                default y
                help
                        This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
+
+       config FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME
+               depends on PACKAGE_fstools
+               bool "Full access time accounting"
+               default n
+               help
+                       This option enables the full access time accounting (warning: it will increase the flash writes).
+
+       config FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB
+               depends on PACKAGE_fstools
+               bool "Compress using zlib"
+               default n
+               help
+                       This option enables the compression using zlib on the storage device.
 endef
 
 define Package/snapshot-tool
@@ -92,8 +108,8 @@ define Package/block-mount/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
-       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
-       $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
+       $(INSTALL_CONF) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
+       $(INSTALL_CONF) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/