cryptodev-linux: move from packages feed
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Sun, 25 Nov 2018 20:12:11 +0000 (20:12 +0000)
committerJohn Crispin <john@phrozen.org>
Mon, 3 Dec 2018 06:50:24 +0000 (07:50 +0100)
The sender domain has a DMARC Reject/Quarantine policy which disallows
sending mailing list messages using the original "From" header.

To mitigate this problem, the original message has been wrapped
automatically by the mailing list software.
This is actually a build dependency for /dev/crypto support in openssl.
Since it is a kernel module, it belongs here anyway.

- Removed Nikos Mavrogiannopoulos as maintainer.
- Streamlined make flags

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
package/kernel/cryptodev-linux/Makefile [new file with mode: 0644]

diff --git a/package/kernel/cryptodev-linux/Makefile b/package/kernel/cryptodev-linux/Makefile
new file mode 100644 (file)
index 0000000..387700e
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=cryptodev-linux
+PKG_VERSION:=1.9.git-2018-11-02
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://github.com/cryptodev-linux/cryptodev-linux
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=f1a693000d116718379f8b53ed7bc6b9c0f7de27
+PKG_MIRROR_HASH:=340d314e2a88bf2449ccee906b141e085d376f6e2a94a64e36254e8376323169
+PKG_LICENSE:=GPL-2.0
+PKG_LICENSE_FILES:=COPYING
+
+PKG_MAINTAINER:=Ansuel Smith <ansuelsmth@gmail.com>
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/cryptodev
+  SUBMENU:=Cryptographic API modules
+  DEFAULT:=m if ALL
+  TITLE:=Driver for cryptographic acceleration
+  URL:=http://cryptodev-linux.org/
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+  DEPENDS:=+kmod-crypto-authenc +kmod-crypto-hash
+  FILES:=$(PKG_BUILD_DIR)/cryptodev.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,cryptodev)
+  MODPARAMS.cryptodev:=cryptodev_verbosity=-1
+endef
+
+define KernelPackage/cryptodev/description
+  This is a driver for that allows to use the Linux kernel supported
+  hardware ciphers by user-space applications.
+endef
+
+define Build/Configure
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(KERNEL_MAKE_FLAGS) \
+               KERNEL_DIR="$(LINUX_DIR)"
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/include/crypto
+       $(CP) $(PKG_BUILD_DIR)/crypto/cryptodev.h $(STAGING_DIR)/usr/include/crypto/
+endef
+
+$(eval $(call KernelPackage,cryptodev))