kernel/modules: snd-pcm-dmaengine only if CONFIG_SND_DMAENGINE_PCM is set
authorJohn Crispin <john@openwrt.org>
Mon, 25 Nov 2013 14:09:48 +0000 (14:09 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 25 Nov 2013 14:09:48 +0000 (14:09 +0000)
Platforms without in-soc audio don't provide CONFIG_SND_DMAENGINE_PCM, thus
the module is not generated.

SVN-Revision: 38913

package/kernel/linux/modules/sound.mk

index 4e1a656dd2707286677786ec2485bce05787e4b6..bed2e3c8021c05214250fa8bd1a4ffd077014abe 100644 (file)
@@ -42,10 +42,10 @@ endif
 
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.12.0)),1)
 SOUNDCORE_LOAD += \
-       snd-pcm-dmaengine
+       $(if $(CONFIG_SND_DMAENGINE_PCM),snd-pcm-dmaengine)
 
 SOUNDCORE_FILES += \
-       $(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko
+       $(if $(CONFIG_SND_DMAENGINE_PCM),$(LINUX_DIR)/sound/core/snd-pcm-dmaengine.ko)
 endif
 
 define KernelPackage/sound-core