hostapd: remove stale WPA_SUPPLICANT_NO_TIMESTAMP_CHECK option
authorChristian Lamparter <chunkeey@gmail.com>
Tue, 11 Dec 2018 17:40:04 +0000 (18:40 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 20 Jun 2019 18:02:29 +0000 (20:02 +0200)
Support to disable the timestamp check for certificates in
wpa_supplicant (Useful for devices without RTC that cannot
reliably get the real date/time) has been accepted in the
upstream hostapd. It's implemented in wpa_supplicant as a
per-AP flag tls_disable_time_checks=[0|1].

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
package/network/services/hostapd/Config.in
package/network/services/hostapd/Makefile

index 578fba839cc8a61f130f2343f77343a2425d225a..1966067219303f3429e16a94d51b38691b933852 100644 (file)
@@ -1,26 +1,4 @@
 # wpa_supplicant config
 # wpa_supplicant config
-config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
-       bool "Disable timestamp check"
-       depends on PACKAGE_wpa-supplicant || \
-                  PACKAGE_wpa-supplicant-openssl || \
-                  PACKAGE_wpa-supplicant-wolfssl || \
-                  PACKAGE_wpa-supplicant-mesh-openssl || \
-                  PACKAGE_wpa-supplicant-mesh-wolfssl || \
-                  PACKAGE_wpa-supplicant-basic || \
-                  PACKAGE_wpa-supplicant-mini || \
-                  PACKAGE_wpa-supplicant-p2p || \
-                  PACKAGE_wpad || \
-                  PACKAGE_wpad-openssl || \
-                  PACKAGE_wpad-wolfssl || \
-                  PACKAGE_wpad-basic || \
-                  PACKAGE_wpad-mini || \
-                  PACKAGE_wpad-mesh-openssl || \
-                  PACKAGE_wpad-mesh-wolfssl
-       default n
-       help
-         This disables the timestamp check for certificates in wpa_supplicant
-         Useful for devices without RTC that cannot reliably get the real date/time
-
 config WPA_RFKILL_SUPPORT
        bool "Add rfkill support"
        depends on PACKAGE_wpa-supplicant || \
 config WPA_RFKILL_SUPPORT
        bool "Add rfkill support"
        depends on PACKAGE_wpa-supplicant || \
index 235f178bc9776956109a2597e7176b7437509fc2..e389efccb23196b865956c1467a664b7eae6df99 100644 (file)
@@ -22,7 +22,6 @@ PKG_CPE_ID:=cpe:/a:w1.fi:hostapd
 PKG_BUILD_PARALLEL:=1
 
 PKG_CONFIG_DEPENDS:= \
 PKG_BUILD_PARALLEL:=1
 
 PKG_CONFIG_DEPENDS:= \
-       CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
        CONFIG_PACKAGE_kmod-ath9k \
        CONFIG_PACKAGE_kmod-cfg80211 \
        CONFIG_PACKAGE_hostapd \
        CONFIG_PACKAGE_kmod-ath9k \
        CONFIG_PACKAGE_kmod-cfg80211 \
        CONFIG_PACKAGE_hostapd \
@@ -123,9 +122,6 @@ ifneq ($(LOCAL_TYPE),hostapd)
     endif
   endif
 
     endif
   endif
 
-  ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
-    TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
-  endif
   ifdef CONFIG_WPA_RFKILL_SUPPORT
     DRIVER_MAKEOPTS += NEED_RFKILL=y
   endif
   ifdef CONFIG_WPA_RFKILL_SUPPORT
     DRIVER_MAKEOPTS += NEED_RFKILL=y
   endif