dnsmasq: allow dnsmasq variants to be included in image
authorHenrique de Moraes Holschuh <henrique@nic.br>
Mon, 27 Aug 2018 11:31:29 +0000 (08:31 -0300)
committerHans Dedecker <dedeckeh@gmail.com>
Thu, 6 Sep 2018 15:57:59 +0000 (17:57 +0200)
The dnsmasq variants should provide dnsmasq, otherwise it is impossible
to include them in the image.

This change allows one to have CONFIG_PACKAGE_dnsmasq=m and
CONFIG_PACKAGE_dnsmasq-full=y, e.g. because you want DNSSEC support, or
IPSETs suport on your 3000-devices fleet ;-)

Signed-off-by: Henrique de Moraes Holschuh <henrique@nic.br>
package/network/services/dnsmasq/Makefile

index 39889639a51fa23772e09d8c8f7c283bde5b56bc..68fd653699913f48a672b2130a1deed253da7169 100644 (file)
@@ -53,6 +53,7 @@ $(call Package/dnsmasq/Default)
   TITLE += (with DHCPv6 support)
   DEPENDS+=@IPV6
   VARIANT:=dhcpv6
+  PROVIDES:=dnsmasq
 endef
 
 define Package/dnsmasq-full
@@ -62,6 +63,7 @@ $(call Package/dnsmasq/Default)
        +PACKAGE_dnsmasq_full_ipset:kmod-ipt-ipset \
        +PACKAGE_dnsmasq_full_conntrack:libnetfilter-conntrack
   VARIANT:=full
+  PROVIDES:=dnsmasq
 endef
 
 define Package/dnsmasq/description