mtd: fix compile warnings
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Mar 2018 23:53:32 +0000 (00:53 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 17 Mar 2018 23:59:18 +0000 (00:59 +0100)
This callback should have one parameter less, this parameter is not used
so this was not a so big problem.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/utils/mtd-utils/patches/010-fix-rpmatch.patch
package/utils/mtd-utils/patches/130-lzma_jffs2.patch

index 9d0de7f5214036cfabe425b180f70659629c7ddf..8374a26e9bbb83b35ef3750721eb031d6ea17084 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/common.h
 +++ b/include/common.h
-@@ -137,10 +137,12 @@ static inline bool prompt(const char *ms
+@@ -152,10 +152,12 @@ static inline bool prompt(const char *ms
                }
  
                if (strcmp("\n", line) != 0) {
index 8c3794d769ee7679bea14918f7ba3aebc5c599a7..abf05e47f22363471fe5c985e7dff3760a72921d 100644 (file)
@@ -2,7 +2,7 @@
 +++ b/Makefile
 @@ -3,7 +3,7 @@
  
- VERSION = 1.5.1
+ VERSION = 1.5.2
  
 -CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
 +CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS) -I./include/linux/lzma
 +}
 +
 +STATIC int jffs2_lzma_compress(unsigned char *data_in, unsigned char *cpage_out,
-+                            uint32_t *sourcelen, uint32_t *dstlen, void *model)
++                            uint32_t *sourcelen, uint32_t *dstlen)
 +{
 +      SizeT compress_size = (SizeT)(*dstlen);
 +      int ret;
 +}
 +
 +STATIC int jffs2_lzma_decompress(unsigned char *data_in, unsigned char *cpage_out,
-+                               uint32_t srclen, uint32_t destlen, void *model)
++                               uint32_t srclen, uint32_t destlen)
 +{
 +      int ret;
 +      SizeT dl = (SizeT)destlen;