build: trigger pacakge index creation for all feeds if required
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 26 May 2015 11:37:05 +0000 (11:37 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 26 May 2015 11:37:05 +0000 (11:37 +0000)
When CONFIG_PER_FEED_REPO_ADD_DISABLED is set, trigger index creation for
any available feed, regardless of whether there where binaries built or not.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 45765

package/Makefile

index 94b807f5d54757c63f60d26fbb626ef894282058..a601dcbb31bb31c2e73ffe428aee1c0c9942a168 100644 (file)
@@ -132,7 +132,11 @@ endif
 
 PACKAGE_SUBDIRS=.
 ifneq ($(CONFIG_PER_FEED_REPO),)
-  PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  ifneq ($(CONFIG_PER_FEED_REPO_ADD_DISABLED),)
+    PACKAGE_SUBDIRS=base $(FEEDS_AVAILABLE)
+  else
+    PACKAGE_SUBDIRS=base $(FEEDS_ENABLED)
+  endif
 endif
 
 $(curdir)/index: FORCE