ar71xx: create image for the TP-Link TL-WR743ND v1
authorGabor Juhos <juhosg@openwrt.org>
Wed, 21 Sep 2011 11:47:44 +0000 (11:47 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Wed, 21 Sep 2011 11:47:44 +0000 (11:47 +0000)
Same hardware as WR741ND but with PoE support.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
SVN-Revision: 28271

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index f5a7a24a9319b56b0b68df0bfc64f57a811c2693..c770d4915110de839924b3cabef1fa5d7eba43a3 100644 (file)
@@ -84,6 +84,17 @@ endef
 $(eval $(call Profile,TLWR740NV3))
 
 
+define Profile/TLWR743NDV1
+       NAME:=TP-LINK TL-WR743ND v1
+       PACKAGES:=
+endef
+
+define Profile/TLWR743NDV1/Description
+       Package set optimized for the TP-LINK TL-WR743ND v1.
+endef
+
+$(eval $(call Profile,TLWR743NDV1))
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
        PACKAGES:=
index d808a1d8aa7468b96856b9523dbc73cf969807c3..e4163b33e5705e9edd665993f435657929500699 100644 (file)
@@ -596,6 +596,10 @@ define Image/Build/Profile/TLWR740NV3
        $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v3,$(tlwe740nv3_cmdline),TL-WR740Nv3)
 endef
 
+define Image/Build/Profile/TLWR743NDV1
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr743nd-v1,$(tlwe741ndv1_cmdline),TL-WR743NDv1)
+endef
+
 tlwr841nv15_cmdline=board=TL-WR841N-v1.5 console=ttyS0,115200
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,$(tlwr841nv15_cmdline),TL-WR841Nv1.5)
@@ -709,6 +713,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR740NV1,$(1))
        $(call Image/Build/Profile/TLWR740NV3,$(1))
+       $(call Image/Build/Profile/TLWR743NDV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))