kernel: package rtc-em3027 module
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Mon, 1 Apr 2019 17:25:42 +0000 (19:25 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Apr 2019 12:48:46 +0000 (14:48 +0200)
Support for Microelectronic EM3027 real time clock chip.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/kernel/linux/modules/other.mk

index 220452df9bf79f2f12173b69e9c8f47e4fc80a10..e279616f206ee3147754fc703f2fc72f808e42df 100644 (file)
@@ -528,6 +528,24 @@ endef
 $(eval $(call KernelPackage,rtc-ds1672))
 
 
+define KernelPackage/rtc-em3027
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Microelectronic EM3027 RTC support
+  DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
+  DEPENDS:=+kmod-i2c-core
+  KCONFIG:=CONFIG_RTC_DRV_EM3027 \
+       CONFIG_RTC_CLASS=y
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-em3027.ko
+  AUTOLOAD:=$(call AutoProbe,rtc-em3027)
+endef
+
+define KernelPackage/rtc-em3027/description
+ Kernel module for Microelectronic EM3027 RTC.
+endef
+
+$(eval $(call KernelPackage,rtc-em3027))
+
+
 define KernelPackage/rtc-isl1208
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Intersil ISL1208 RTC support