imx6: image: ventana: Add missing BOOT_SCRIPT variable
authorPetr Štetiar <ynezz@true.cz>
Fri, 23 Nov 2018 09:54:25 +0000 (10:54 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Nov 2018 18:23:03 +0000 (19:23 +0100)
This is probably theoretical problem as the Ventana is defined first in
the image Makefile, but once the position of the definition would change
in the future (alphabetical sorting?) it would get bootscript from the
previous board which would have BOOT_SCRIPT set.

Cc: Tim Harvey <tharvey@gateworks.com>
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/imx6/image/Makefile

index f13412f1e3002f41053419a7952c77b20d0940c6..9dd5b520a1f1c95530e3787d1583dc8ae58b1817 100644 (file)
@@ -136,6 +136,7 @@ define Device/ventana
   IMAGES := nand.ubi bootfs.tar.gz
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
   UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
+  BOOT_SCRIPT := bootscript-ventana
   IMAGE/nand.ubi := append-ubi
   IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)