x86: add ib700wdt module for x86 qemu watchdogs
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 1 May 2022 12:10:25 +0000 (14:10 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 7 May 2022 12:31:22 +0000 (14:31 +0200)
QEMU+Libvirt can emulate the ib700wdt watchdogs
which due to its I/O-Port mapping makes it x86
specific.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/x86/modules.mk

index fcf8dfcdff60e1fb4fc24419791867e36c119c2f..a57a470e8d5f30949a67c351c8a404c122b8eef4 100644 (file)
@@ -67,6 +67,24 @@ endef
 $(eval $(call KernelPackage,sp5100-tco))
 
 
+define KernelPackage/ib700-wdt
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=IB700 SBC Watchdog Timer
+  DEPENDS:=@TARGET_x86
+  KCONFIG:=CONFIG_IB700_WDT
+  FILES:=$(LINUX_DIR)/drivers/watchdog/ib700wdt.ko
+  AUTOLOAD:=$(call AutoLoad,50,ib700wdt,1)
+endef
+
+define KernelPackage/ib700-wdt/description
+  Kernel module for the hardware watchdog on the IB700 Single
+  Board Computer produced by TMC Technology (www.tmc-uk.com).
+  Also used by QEMU/libvirt.
+endef
+
+$(eval $(call KernelPackage,ib700-wdt))
+
+
 define KernelPackage/pcengines-apuv2
   SUBMENU:=$(OTHER_MENU)
   TITLE:=PC Engines APUv2/3 front button and LEDs driver