kernel: netsupport: Extract act_police
authorHauke Mehrtens <hmehrtens@maxlinear.com>
Thu, 4 Aug 2022 16:44:51 +0000 (18:44 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 6 Aug 2022 19:32:35 +0000 (21:32 +0200)
This extracts kmod-sched-act-police to allow using it without adding all
the packages from the big kmod-sched package.

Signed-off-by: Hauke Mehrtens <hmehrtens@maxlinear.com>
package/kernel/linux/modules/netsupport.mk

index 74af7a9e411de4b216c6b234c5e59a61b42a55c2..9b99aa1d21b429f0c8e2050fc77fa4d9ba6e77a3 100644 (file)
@@ -775,6 +775,18 @@ endef
 $(eval $(call KernelPackage,sched-core))
 
 
+define KernelPackage/sched-act-police
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Traffic Policing
+  DEPENDS:=+kmod-sched-core
+  KCONFIG:=CONFIG_NET_ACT_POLICE
+  FILES:=$(LINUX_DIR)/net/sched/act_police.ko
+  AUTOLOAD:=$(call AutoProbe,act_police)
+endef
+
+$(eval $(call KernelPackage,sched-act-police))
+
+
 define KernelPackage/sched-act-sample
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Traffic Sampling
@@ -968,7 +980,7 @@ endef
 $(eval $(call KernelPackage,bpf-test))
 
 
-SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_police act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
+SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
 SCHED_FILES_EXTRA = $(foreach mod,$(SCHED_MODULES_EXTRA),$(LINUX_DIR)/net/sched/$(mod).ko)
 
 define KernelPackage/sched
@@ -984,7 +996,6 @@ define KernelPackage/sched
        CONFIG_NET_SCH_TEQL \
        CONFIG_NET_SCH_FQ \
        CONFIG_NET_SCH_PIE \
-       CONFIG_NET_ACT_POLICE \
        CONFIG_NET_ACT_IPT \
        CONFIG_NET_ACT_PEDIT \
        CONFIG_NET_ACT_SIMP \