nettle: update to 3.7.3
authorRosen Penev <rosenp@gmail.com>
Tue, 13 Jul 2021 20:30:24 +0000 (13:30 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 8 Aug 2021 17:50:46 +0000 (19:50 +0200)
Switch to AUTORELEASE to avoid manual increments.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/nettle/Makefile
package/libs/nettle/patches/100-portability.patch

index b15ea0fa07362e2f6cded116f6cd193ff27475d9..3b4bd9d05343764355da4cdb657942fd208d554c 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nettle
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nettle
-PKG_VERSION:=3.6
-PKG_RELEASE:=1
+PKG_VERSION:=3.7.3
+PKG_RELEASE:=$(AUTORELEASE)
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/nettle
 PKG_USE_MIPS16:=0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/nettle
-PKG_HASH:=d24c0d0f2abffbc8f4f34dcf114b0f131ec3774895f3555922fe2f40f3d5e3f1
+PKG_HASH:=661f5eb03f048a3b924c3a8ad2515d4068e40f67e774e8a26827658007e3bcf0
 
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
 
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
index 2849e53eab8855fd40ab8cb158a00f6e1d79a3ce..5bbae227527c53558c40d4ea7182c9ae66e39b0c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure
 +++ b/configure
 --- a/configure
 +++ b/configure
-@@ -4635,6 +4635,7 @@ $as_echo_n "checking build system compil
+@@ -4661,6 +4661,7 @@ $as_echo_n "checking build system compil
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
@@ -8,7 +8,7 @@
  int
  main ()
  {
  int
  main ()
  {
-@@ -4667,6 +4668,7 @@ $as_echo_n "checking build system compil
+@@ -4693,6 +4694,7 @@ $as_echo_n "checking build system compil
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
@@ -16,7 +16,7 @@
  int
  main ()
  {
  int
  main ()
  {
-@@ -4703,6 +4705,7 @@ $as_echo_n "checking build system compil
+@@ -4729,6 +4731,7 @@ $as_echo_n "checking build system compil
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
  # remove anything that might look like compiler output to our "||" expression
  rm -f conftest* a.out b.out a.exe a_out.exe
  cat >conftest.c <<EOF
@@ -24,7 +24,7 @@
  int
  main ()
  {
  int
  main ()
  {
-@@ -4753,6 +4756,7 @@ else
+@@ -4779,6 +4782,7 @@ else
    gmp_cv_prog_exeext_for_build="$EXEEXT"
  else
    cat >conftest.c <<EOF
    gmp_cv_prog_exeext_for_build="$EXEEXT"
  else
    cat >conftest.c <<EOF