ipq40xx: Convert plasmacloud,pa2200 to DSA
authorSven Eckelmann <sven@narfation.org>
Mon, 24 Oct 2022 16:55:44 +0000 (18:55 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Nov 2022 14:26:34 +0000 (15:26 +0100)
* ethernet1:

  - physical port label "Ethernet 1"
  - its mac address is printed on the device label

* ethernet2:

  - physical port label "Ethernet 2"
  - can be used to power the device

Both ports are not marked by there role (because the vendor firmware
automatically detects roles) but the "Ethernet 2" port was used in the past
for "WAN" functionality in OpenWrt.

Tested-by: Michaƫl BILCOT <michael.bilcot@gmail.com>
Signed-off-by: Sven Eckelmann <sven@narfation.org>
target/linux/ipq40xx/base-files/etc/board.d/02_network
target/linux/ipq40xx/files/arch/arm/boot/dts/qcom-ipq4019-pa2200.dts
target/linux/ipq40xx/image/generic.mk

index dc111044e84c8731963363396a7e5b3027c87234..24b59d6630cc7c91bb4d005c7f6039fb756b4d5c 100644 (file)
@@ -77,7 +77,8 @@ ipq40xx_setup_interfaces()
        openmesh,a62)
                ucidef_set_interfaces_lan_wan "ethernet2" "ethernet1"
                ;;
-       plasmacloud,pa1200)
+       plasmacloud,pa1200|\
+       plasmacloud,pa2200)
                ucidef_set_interfaces_lan_wan "ethernet1" "ethernet2"
                ;;
        zte,mf286d)
index d7dcf053be4001ab76ac735280430b9682fe7455..259ea7bb47abd9b4408c6f8d1472bca07e0adb5f 100644 (file)
                        status = "okay";
                };
 
-               mdio@90000 {
-                       status = "okay";
-               };
-
                tcsr@1949000 {
                        compatible = "qcom,tcsr";
                        reg = <0x1949000 0x100>;
@@ -63,6 +59,7 @@
                led-failsafe = &led_status_blue;
                led-running = &led_power_orange;
                led-upgrade = &led_status_blue;
+               label-mac-device = &swport4;
        };
 
        leds {
        };
 };
 
+&mdio {
+       status = "okay";
+};
+
+&gmac {
+       status = "okay";
+};
+
+&switch {
+       status = "okay";
+};
+
+&swport4 {
+       status = "okay";
+       label = "ethernet1";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac0>;
+};
+
+&swport5 {
+       status = "okay";
+       label = "ethernet2";
+
+       nvmem-cell-names = "mac-address";
+       nvmem-cells = <&macaddr_gmac1>;
+};
+
 &wifi0 {
        status = "okay";
        qcom,ath10k-calibration-variant = "PlasmaCloud-PA2200";
index 8b2851f83ec2370fe14cd34faee64319dd4fdcb8..d05e2c72ec1e14b6ccb95836c097932fd46d7fbd 100644 (file)
@@ -974,8 +974,7 @@ define Device/plasmacloud_pa2200
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
 endef
-# Missing DSA Setup
-#TARGET_DEVICES += plasmacloud_pa2200
+TARGET_DEVICES += plasmacloud_pa2200
 
 define Device/qcom_ap-dk01.1-c1
        DEVICE_VENDOR := Qualcomm Atheros