ar71xx: add userspace support for D-Link DIR-869 A1, generate images
authorFlorian Beier <beier.florian@gmail.com>
Tue, 11 Oct 2016 18:32:26 +0000 (20:32 +0200)
committerMatthias Schiffer <mschiffer@universe-factory.net>
Tue, 11 Oct 2016 20:58:37 +0000 (22:58 +0200)
Signed-off-by: Florian Beier <beier.florian@gmail.com>
[Matthias Schiffer: fix factory image, improve commit message]
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/generic.mk

index a2bd6b11bcfed43bcfeb2e5c9206118523eb1204..4ef43cf5a4a114e098bb953becaa7c1edec5e91e 100755 (executable)
@@ -285,6 +285,7 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:lan" "1:lan" "3@eth1"
                ;;
+       dir-869-a1|\
        epg5000|\
        esr1750)
                ucidef_add_switch "switch0" \
@@ -434,6 +435,7 @@ ar71xx_setup_macs()
        esr900)
                wan_mac=$(mtd_get_mac_ascii u-boot-env "wanaddr")
                ;;
+       dir-869-a1|\
        mynet-n750)
                wan_mac=$(mtd_get_mac_ascii devdata "wanmac")
                ;;
index d6e257d6372e6913a4d3ad8071aa122a14b41e96..d5ddb51240c9a12dd2ea7c8ddd52f99f4862c8f6 100644 (file)
@@ -110,6 +110,9 @@ get_status_led() {
        dir-835-a1)
                status_led="d-link:amber:power"
                ;;
+       dir-869-a1)
+               status_led="d-link:white:status"
+               ;;
        dlan-hotspot)
                status_led="devolo:green:wifi"
                ;;
index 0e93feb19cdde5f4df35b5ae596d15eac2aa97ee..a0a111b3d1520d6c9d66e767b547cec579a22f7c 100644 (file)
@@ -62,6 +62,7 @@ case "$FIRMWARE" in
                ath10kcal_extract "caldata" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) +2)
                ;;
+       dir-869-a1 | \
        qihoo-c301)
                ath10kcal_extract "radiocfg" 20480 2116
                ath10kcal_patch_mac $(mtd_get_mac_ascii devdata wlan5mac)
index dae6fb2a2d7a119d7243dbb559e184db16778279..a8ea7d48f2527a9160557ac06144b7556fbe3728 100755 (executable)
@@ -536,6 +536,9 @@ ar71xx_board_detect() {
        *"DIR-835 rev. A1")
                name="dir-835-a1"
                ;;
+       *"DIR-869 rev. A1")
+               name="dir-869-a1"
+               ;;
        *"dLAN Hotspot")
                name="dlan-hotspot"
                ;;
index 559f97d1bbf8eafaab169d3825bf2e57927884e7..010442c0cc97b7fee59cc022b6a134ab974c392a 100755 (executable)
@@ -453,6 +453,7 @@ platform_check_image() {
                merakinand_do_platform_check $board $1
                return $?
                ;;
+       dir-869-a1|\
        mynet-n600|\
        mynet-n750|\
        qihoo-c301)
index c96a9929e0aeabacad9df88614b4c7603e15f286..c2a25779fa9f4cc2686586dc23a5b7c60080747f 100644 (file)
@@ -505,6 +505,20 @@ define Device/seama
   DEVICE_VARS += SEAMA_SIGNATURE
 endef
 
+define Device/dir-869-a1
+$(Device/seama)
+  DEVICE_TITLE := D-Link DIR-869 rev. A1
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+  BOARDNAME = DIR-869-A1
+  IMAGE_SIZE = 15872k
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,64k(devdata)ro,64k(devconf)ro,15872k(firmware),64k(radiocfg)ro
+  SEAMA_SIGNATURE := wrgac54_dlink.2015_dir869
+  IMAGE/factory.bin := \
+       $$(IMAGE/default) | pad-rootfs -x 64 | \
+       seama | seama-seal -m "signature=$$$$(SEAMA_SIGNATURE)" | \
+       check-size $$$$(IMAGE_SIZE)
+endef
+
 define Device/mynet-n600
 $(Device/seama)
   DEVICE_TITLE := Western Digital My Net N600
@@ -535,4 +549,4 @@ $(Device/seama)
   SEAMA_SIGNATURE := wrgac26_qihoo360_360rg
 endef
 
-TARGET_DEVICES += mynet-n600 mynet-n750 qihoo-c301
+TARGET_DEVICES += dir-869-a1 mynet-n600 mynet-n750 qihoo-c301