rules.mk: add newline definition
authorJohn Crispin <john@openwrt.org>
Sun, 15 Mar 2015 19:47:46 +0000 (19:47 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 15 Mar 2015 19:47:46 +0000 (19:47 +0000)
To be used for stuff like $(subst $(space),$(newline),$(SOME_VAR))

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
SVN-Revision: 44796

rules.mk

index 078ebe3faace96d3be8cede610a4fe8a444eea8c..e61cc3fde9a100b1e649f3003b316490c9fc5294 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -28,6 +28,11 @@ strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
 define sep
 
+endef
+
+define newline
+
+
 endef
 
 _SINGLE=export MAKEFLAGS=$(space);