ipq806x: drop partitial supported boards
authorMathias Kresin <dev@kresin.me>
Mon, 8 Jan 2018 22:24:44 +0000 (23:24 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 13 Jan 2018 06:33:02 +0000 (07:33 +0100)
There are only artifacts for these boards in our tree and not even
partial support.

Drop teh stale files.

Signed-off-by: Mathias Kresin <dev@kresin.me>
package/firmware/ipq-wifi/Makefile
package/firmware/ipq-wifi/board-nbg6617.bin [deleted file]
package/firmware/ipq-wifi/board-rt-ac58u.bin [deleted file]
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-nbg6617.dts [deleted file]
target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-rt-ac58u.dts [deleted file]
target/linux/ipq806x/patches-4.9/0069-arm-boot-add-dts-files.patch
target/linux/ipq806x/patches-4.9/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch [deleted file]

index aec8bf27c258728f81cca941523ca923a37e2e95..95c56270fe0c936c5c1e78dda107f1614424d151 100644 (file)
@@ -13,7 +13,7 @@ endef
 define Build/Compile
 endef
 
-ALLWIFIBOARDS:=rt-ac58u fritz4040 nbg6617
+ALLWIFIBOARDS:=fritz4040
 ALLWIFIPACKAGES:=$(foreach BOARD,$(ALLWIFIBOARDS),ipq-wifi-$(BOARD))
 
 define Package/ipq-wifi-default
@@ -47,8 +47,6 @@ Don't install it for any other device!
   PREV_BOARD+=ipq-wifi-$(1)
 endef
 
-$(eval $(call generate-ipq-wifi-package,rt-ac58u,board-rt-ac58u.bin,ASUS RT-AC58U/RT-ACRH13))
 $(eval $(call generate-ipq-wifi-package,fritz4040,board-fritz4040.bin,AVM FRITZBox 4040))
-$(eval $(call generate-ipq-wifi-package,nbg6617,board-nbg6617.bin,ZyXEL NBG6617))
 
 $(foreach PACKAGE,$(ALLWIFIPACKAGES),$(eval $(call BuildPackage,$(PACKAGE))))
diff --git a/package/firmware/ipq-wifi/board-nbg6617.bin b/package/firmware/ipq-wifi/board-nbg6617.bin
deleted file mode 100644 (file)
index ab4d43e..0000000
Binary files a/package/firmware/ipq-wifi/board-nbg6617.bin and /dev/null differ
diff --git a/package/firmware/ipq-wifi/board-rt-ac58u.bin b/package/firmware/ipq-wifi/board-rt-ac58u.bin
deleted file mode 100644 (file)
index 379bdc8..0000000
Binary files a/package/firmware/ipq-wifi/board-rt-ac58u.bin and /dev/null differ
diff --git a/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-nbg6617.dts b/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-nbg6617.dts
deleted file mode 100644 (file)
index a00dee7..0000000
+++ /dev/null
@@ -1,135 +0,0 @@
-/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
- *
- * Permission to use, copy, modify, and/or distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- *
- */
-
-#include "qcom-ipq4019-ap.dk01.1.dtsi"
-#include "qcom-ipq4019-bus.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "ZyXEL NBG6617";
-       compatible = "zyxel,nbg6617", "qcom,ipq4019";
-
-       memory {
-               device_type = "memory";
-               reg = <0x80000000 0x10000000>;
-       };
-
-       aliases {
-               led-boot = &power;
-               led-failsafe = &power;
-               led-running = &power;
-               led-upgrade = &power;
-       };
-
-       reserved-memory {
-               #address-cells = <0x1>;
-               #size-cells = <0x1>;
-               ranges;
-
-               rsvd1@87000000 {
-                       reg = <0x87000000 0x0500000>;
-                       no-map;
-               };
-
-               wifi_dump@87500000 {
-                       reg = <0x87500000 0x600000>;
-                       no-map;
-               };
-
-               rsvd2@87B00000 {
-                       reg = <0x87b00000 0x500000>;
-                       no-map;
-               };
-       };
-
-       soc {
-               pinctrl@1000000 {
-                       led_pinmux {
-                               mux {
-                                       pins = "gpio0", "gpio1", "gpio3", "gpio5", "gpio58";
-                                       drive-strength = <0x8>;
-                                       bias-pull-up;
-                                       output-high;
-                               };
-                       };
-               };
-       };
-
-       gpio-keys {
-               compatible = "gpio-keys";
-
-               wlan {
-                       label = "wlan";
-                       gpios = <&tlmm 0x2 GPIO_ACTIVE_HIGH>;
-                       linux,code = <KEY_RFKILL>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&tlmm 0x3f GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-
-               reset {
-                       label = "reset";
-                       gpios = <&tlmm 0x4 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               power: power {
-                       label = "nbg6617:green:power";
-                       gpios = <&tlmm 0x3 GPIO_ACTIVE_HIGH>;
-               };
-
-               wps {
-                       label = "nbg6617:green:wps";
-                       gpios = <&tlmm 0x1 GPIO_ACTIVE_HIGH>;
-               };
-
-               wlan2G {
-                       label = "nbg6617:green:wlan2G";
-                       gpios = <&tlmm 0x3a GPIO_ACTIVE_HIGH>;
-               };
-
-               wlan5G {
-                       label = "nbg6617:green:wlan5G";
-                       gpios = <&tlmm 0x5 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&spi_0 { /* BLSP1 QUP1 */
-       n25q128a11@0 {
-               status = "okay";
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition0@0 {
-                               label = "all";
-                               reg = <0x00000000 0x08000000>;
-                               read-only; /* for now */
-                       };
-               };
-       };
-};
diff --git a/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-rt-ac58u.dts b/target/linux/ipq806x/files-4.9/arch/arm/boot/dts/qcom-ipq4019-rt-ac58u.dts
deleted file mode 100644 (file)
index 6efd0df..0000000
+++ /dev/null
@@ -1,197 +0,0 @@
-/* Copyright (c) 2015, The Linux Foundation. All rights reserved.
- *
- * Permission to use, copy, modify, and/or distribute this software for any
- * purpose with or without fee is hereby granted, provided that the above
- * copyright notice and this permission notice appear in all copies.
- *
- * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
- * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
- * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
- * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
- * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
- * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
- * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
- *
- */
-
-#include "qcom-ipq4019-ap.dk01.1.dtsi"
-#include "qcom-ipq4019-bus.dtsi"
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "ASUS RT-AC58U";
-       compatible = "asus,rt-ac58u", "qcom,ipq4019";
-
-       memory {
-               device_type = "memory";
-               reg = <0x80000000 0x8000000>;
-       };
-
-       aliases {
-               led-boot = &power;
-               led-failsafe = &power;
-               led-running = &power;
-               led-upgrade = &power;
-       };
-
-       reserved-memory {
-               #address-cells = <0x1>;
-               #size-cells = <0x1>;
-               ranges;
-
-               rsvd1@87E00000 {
-                       reg = <0x87e00000 0x200000>;
-                       no-map;
-               };
-       };
-
-       gpio-keys {
-               compatible = "gpio-keys";
-
-               reset {
-                       label = "reset";
-                       gpios = <&tlmm 4 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&tlmm 63 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_WPS_BUTTON>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               power: status {
-                       label = "rt-ac58u:blue:status";
-                       gpios = <&tlmm 3 GPIO_ACTIVE_HIGH>;
-               };
-
-               wan {
-                       label = "rt-ac58u:blue:wan";
-                       gpios = <&tlmm 1 GPIO_ACTIVE_HIGH>;
-               };
-
-               wlan2G {
-                       label = "rt-ac58u:blue:wlan2G";
-                       gpios = <&tlmm 58 GPIO_ACTIVE_HIGH>;
-               };
-
-               wan5G {
-                       label = "rt-ac58u:blue:wlan5G";
-                       gpios = <&tlmm 5 GPIO_ACTIVE_HIGH>;
-               };
-
-               usb {
-                       label = "rt-ac58u:blue:usb";
-                       gpios = <&tlmm 0 GPIO_ACTIVE_HIGH>;
-               };
-
-               lan {
-                       label = "rt-ac58u:blue:lan";
-                       gpios = <&tlmm 2 GPIO_ACTIVE_HIGH>;
-               };
-       };
-};
-
-&spi_0_pins {
-       pinmux_cs {
-               function = "gpio";
-               pins = "gpio54", "gpio59";
-       };
-       pinconf_cs {
-               pins = "gpio54", "gpio59";
-               drive-strength = <2>;
-               bias-disable;
-               output-high;
-       };
-};
-
-&spi_0 { /* BLSP1 QUP1 */
-       cs-gpios = <&tlmm 54 0>,
-                  <&tlmm 59 0>;
-
-       m25p80@0 {
-               #address-cells = <1>;
-               #size-cells = <0>;
-               /*
-                * U-boot looks for "n25q128a11" node,
-                * if we don't have it, it will spit out the following warning:
-                * "ipq: fdt fixup unable to find compatible node".
-                */
-               compatible = "mx25l1606e", "n25q128a11";
-               reg = <0>;
-               linux,modalias = "m25p80", "mx25l1606e", "n25q128a11";
-               spi-max-frequency = <24000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition0@0 {
-                               label = "SBL1";
-                               reg = <0x00000000 0x00040000>;
-                               read-only;
-                       };
-                       partition1@40000 {
-                               label = "MIBIB";
-                               reg = <0x00040000 0x00020000>;
-                               read-only;
-                       };
-                       partition2@60000 {
-                               label = "QSEE";
-                               reg = <0x00060000 0x00060000>;
-                               read-only;
-                       };
-                       partition3@c0000 {
-                               label = "CDT";
-                               reg = <0x000c0000 0x00010000>;
-                               read-only;
-                       };
-                       partition4@d0000 {
-                               label = "DDRPARAMS";
-                               reg = <0x000d0000 0x00010000>;
-                               read-only;
-                       };
-                       partition5@e0000 {
-                               label = "APPSBLENV"; /* uboot env*/
-                               reg = <0x000e0000 0x00010000>;
-                               read-only;
-                       };
-                       partition5@f0000 {
-                               label = "APPSBL"; /* uboot */
-                               reg = <0x000f0000 0x00080000>;
-                               read-only;
-                       };
-                       partition5@170000 {
-                               label = "ART";
-                               reg = <0x00170000 0x00010000>;
-                               read-only;
-                       };
-                       /* 0x00180000 - 0x00200000 unused */
-               };
-       };
-
-       mt29f@1 {
-               #address-cells = <1>;
-               #size-cells = <0>;
-               compatible = "spinand,mt29f", "w25n01gv";
-               reg = <1>;
-               spi-max-frequency = <24000000>;
-
-               partitions {
-                       compatible = "fixed-partitions";
-                       #address-cells = <1>;
-                       #size-cells = <1>;
-
-                       partition0@0 {
-                               label = "ubi";
-                               reg = <0x00000000 0x08000000>;
-                       };
-               };
-       };
-};
index bab2808789f687f4665be3ebc666d25af9777a69..a6c66d703cd88b1d3e6aa90d4b5ad7e3a1c2815b 100644 (file)
@@ -10,13 +10,11 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -618,7 +618,18 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -618,7 +618,16 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8084-mtp.dtb \
        qcom-ipq4019-ap.dk01.1-c1.dtb \
        qcom-ipq4019-ap.dk04.1-c1.dtb \
 +      qcom-ipq4019-fritz4040.dtb \
-+      qcom-ipq4019-nbg6617.dtb \
-+      qcom-ipq4019-rt-ac58u.dtb \
        qcom-ipq8064-ap148.dtb \
 +      qcom-ipq8064-c2600.dtb \
 +      qcom-ipq8064-d7800.dtb \
diff --git a/target/linux/ipq806x/patches-4.9/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch b/target/linux/ipq806x/patches-4.9/400-mtd-ubi-add-quirk-to-autoload-ubi-on-rt-ac58u.patch
deleted file mode 100644 (file)
index ee19f36..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-From b8f3a7ccbeca5bdbd1b6210b94b38d3fef2dd0bd Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@googlemail.com>
-Date: Thu, 19 Jan 2017 01:57:22 +0100
-Subject: [PATCH 16/38] mtd: ubi: add auto_attach HACK for the ASUS RT-AC58U
-
-This patch adds a hack that allows UBI's autoattach feature
-to work with the custom ASUS UBI_DEV partition name.
-
-This is necessary because the vendor's u-boot doesn't leave
-the bootargs / cmdline alone, so the it can't be overwritten
-easily otherwise.
-
-Signed-off-by: Christian Lamparter <chunkeey@googlemail.com>
----
- drivers/mtd/ubi/build.c | 3 +++
- 1 file changed, 3 insertions(+)
-
---- a/drivers/mtd/ubi/build.c
-+++ b/drivers/mtd/ubi/build.c
-@@ -1225,6 +1225,9 @@ static void __init ubi_auto_attach(void)
-       mtd = open_mtd_device("ubi");
-       if (IS_ERR(mtd))
-               mtd = open_mtd_device("data");
-+      /* Hack for the Asus RT-AC58U */
-+      if (IS_ERR(mtd))
-+              mtd = open_mtd_device("UBI_DEV");
-       if (!IS_ERR(mtd)) {
-               size_t len;