ar71xx: fix lzma-loader build with glibc
authorJonas Gorski <jonas.gorski@gmail.com>
Wed, 13 Dec 2017 10:12:11 +0000 (11:12 +0100)
committerJonas Gorski <jonas.gorski@gmail.com>
Wed, 13 Dec 2017 10:34:51 +0000 (11:34 +0100)
For an unknown reason gcc tries to link in crti.o when building with a
glibc toolchain (this does not happen with other targets). Prevent this
by telling gcc explicitly to not do that.

Fixes the following build error:

/home/jonas/git/lede/staging_dir/toolchain-mips_24kc_gcc-5.5.0_glibc/lib/gcc/mips-openwrt-linux-gnu/5.5.0/../../../../mips-openwrt-linux-gnu/lib/crti.o: In function `_init':
(.init+0x18): relocation truncated to fit: R_MIPS_GOT16 against `__gmon_start__'
/home/jonas/git/lede/staging_dir/toolchain-mips_24kc_gcc-5.5.0_glibc/lib/gcc/mips-openwrt-linux-gnu/5.5.0/../../../../mips-openwrt-linux-gnu/lib/crti.o: In function `_init':
(.init+0x28): relocation truncated to fit: R_MIPS_CALL16 against `__gmon_start__'
collect2: error: ld returned 1 exit status

Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
target/linux/ar71xx/image/lzma-loader/src/Makefile

index 682b31fe8c9d01618504975638922165feae5968..c54f64a550b6fab66b87589e335d646b5f91ba19 100644 (file)
@@ -33,7 +33,7 @@ BIN_FLAGS     := -O binary -R .reginfo -R .note -R .comment -R .mdebug \
 CFLAGS         = -D__KERNEL__ -Wall -Wstrict-prototypes -Wno-trigraphs -Os \
                  -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
                  -mno-abicalls -fno-pic -ffunction-sections -pipe -mlong-calls \
-                 -fno-common -ffreestanding -fhonour-copts \
+                 -fno-common -ffreestanding -fhonour-copts -nostartfiles \
                  -mabi=32 -march=mips32r2 \
                  -Wa,-32 -Wa,-march=mips32r2 -Wa,-mips32r2 -Wa,--trap
 CFLAGS         += -D_LZMA_PROB32