improve parallel building
[openwrt/staging/mkresin.git] / include / image.mk
index 06516791805b082711a321d483977c675d976ad7..c738146851d58b2ae2709ddb9c16a1b487ba9b8d 100644 (file)
@@ -57,7 +57,7 @@ endif
 
 
 define Image/mkfs/prepare/default
-       find $(BUILD_DIR)/root -type f -not -perm +0100 | xargs chmod 0644
+       find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs chmod 0644
        find $(BUILD_DIR)/root -type f -perm +0100 | xargs chmod 0755
        find $(BUILD_DIR)/root -type d | xargs chmod 0755
        mkdir -p $(BUILD_DIR)/root/tmp