prepare for the transition to linux 2.6.22 - make it possible to override the kernel...
[openwrt/staging/mkresin.git] / include / kernel-defaults.mk
index 84030a6d2dc0677ba2a56b7c80c0acc943fa948a..6930a962a565fc8e90e9d375acc1aa052d34375c 100644 (file)
@@ -47,9 +47,9 @@ define Kernel/Configure/2.6
 endef
 define Kernel/Configure/Default
        @if [ -f "./config/profile-$(PROFILE)" ]; then \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) '+' $(LINUX_CONFIG) ./config/profile-$(PROFILE) > $(LINUX_DIR)/.config; \
        else \
-               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_PLATFORM_DIR)/config-template $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
+               $(SCRIPT_DIR)/config.pl '+' $(GENERIC_LINUX_CONFIG) $(LINUX_CONFIG) > $(LINUX_DIR)/.config; \
        fi
        $(call Kernel/Configure/$(KERNEL))
        rm -rf $(KERNEL_BUILD_DIR)/modules