licensing: Add licensing metadata to many packages Two new variables are introduces...
[openwrt/staging/mkresin.git] / include / package-ipkg.mk
index 665aac5d65bfa0191fca16f9d674268ae47ee2ed..4ee0a96ad108561a4a6fb91fcff56d56536f51be 100644 (file)
@@ -149,6 +149,10 @@ ifeq ($(DUMP),)
                echo "Depends: $$$$DEPENDS"; \
                echo "Provides: $(PROVIDES)"; \
                echo "Source: $(SOURCE)"; \
+               echo "SourceFile: $(PKG_SOURCE)"; \
+               echo "SourceURL: $(PKG_SOURCE_URL)"; \
+               echo "License: $(PKG_LICENSE)"; \
+               echo "LicenseFiles: $(PKG_LICENSE_FILES)"; \
                echo "Section: $(SECTION)"; \
                echo "Status: unknown $(if $(filter hold,$(PKG_FLAGS)),hold,ok) not-installed"; \
                echo "Essential: $(if $(filter essential,$(PKG_FLAGS)),yes,no)"; \