commit profile support for base-files... patches still need to be done
[openwrt/staging/mkresin.git] / include / target.mk
index bd3ceb955b7f00d0f76eb6d6305a2d9be5bd5e68..6a136a1bee4dbd16d7eee3a4b84f45b7c6075dd2 100644 (file)
@@ -5,6 +5,21 @@
 # See /LICENSE for more information.
 #
 
+define AddProfile
+  $(eval $(call Profile/Default))
+  $(eval $(call Profile/$(1)))
+  ifneq ($(ID),)
+    PROFILE:=$(ID)
+       $(ID)_NAME:=$(NAME)
+       $(ID)_PACKAGES:=$(PACKAGES)
+    ifneq ($(KCONFIG),)
+      PROFILE_LIST += \
+               echo '$(ID):'; [ -z '$(NAME)' ] || echo '       $(NAME)'; echo '        Packages: $(PACKAGES)';
+    endif
+  endif
+endef
+
+
 include $(TMP_DIR)/.target.mk
 
 ifeq ($(IB),1)