fix unknown arch in ipkg: use our ARCH instead of busybox's TARGET_ARCH (closes:...
[openwrt/staging/mkresin.git] / openwrt / package / busybox / Makefile
index 9e30492e9062b51134dcd0eb7df78f5f1c29e2ff..c87701ad1e5a24f94801c8b1d1f82571539e5e64 100644 (file)
@@ -46,11 +46,21 @@ define Build/Configure
                oldconfig
 endef
 
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               CROSS="$(TARGET_CROSS)" \
+               EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
+               all
+endef
+
 define Package/busybox/install
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS="$(TARGET_CROSS)" \
                EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
+               IPKG_ARCH="$(ARCH)" \
                PREFIX="$(1)" \
                install
        -rm -rf $(1)/lib64