normalize Makefiles.
[openwrt/staging/mkresin.git] / openwrt / package / ipsec-tools / Makefile
index 9e14b400750addc709a1bc4169a5f1a40e5f5752..58dccca62ad5ba09e44c98e443b7779434954c58 100644 (file)
@@ -12,12 +12,14 @@ PKG_SOURCE_URL:=@SF/ipsec-tools
 PKG_MD5SUM:=d0242a943c82c0cbf28005966ff35e21
 PKG_CAT:=bzcat
 
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
 include $(TOPDIR)/package/rules.mk
 
 define Package/ipsec-tools
 SECTION:=base
 CATEGORY:=Network
-DEFAULT:=y
+DEPENDS:=@LINUX_2_6
 TITLE:=IPsec management tools
 DESCRIPTION:=IPsec management tools
 URL:=http://ipsec-tools.sourceforge.net/
@@ -66,13 +68,17 @@ define Build/Configure
        );
 endef
 
+define Build/Compile
+       $(call Build/Compile/Default,install)
+endef
+
 define Package/ipsec-tools/install
        install -d -m0755 $(1)/etc
+       install -m0600 $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
        install -d -m0755 $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       $(CP) $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(1)/etc/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libipsec.so.* $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libracoon.so.* $(1)/usr/lib/
+       install -d -m0755 $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/plainrsa-gen $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/racoon $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/racoonctl $(1)/usr/sbin/